nix-configs/nixos-modules/common/nix.nix
2024-09-27 21:39:12 -04:00

30 lines
626 B
Nix

{ pkgs, ... }:
{
programs.git.enable = true;
programs.nh = {
enable = true;
clean.enable = true;
clean.extraArgs = "--keep-since 7d";
};
nix = {
settings = {
experimental-features = [
"nix-command"
"flakes"
];
use-xdg-base-directories = true;
};
optimise.automatic = true;
};
environment.systemPackages = [ pkgs.nix-output-monitor ];
system.autoUpgrade = {
enable = true;
flake = "git+https://git.icanttype.org/cdombroski/nix-configs.git";
allowReboot = true;
rebootWindow = {
lower = "02:00";
upper = "06:00";
};
};
}